HighPoint, Motherboards & A Flashing Cursor

I was lucky enough to take part in an Intel retailer incentive that netted me an Intel P4304BTLSFCN barebones system with an Intel Xeon 1230 and an Intel AXXRMS2AF080 on-board RAID module. I added some hard drives and 16 GB of ECC DDR3 RAM.

This is my new home server and since it has plenty of horsepower I installed Windows Server 2008 R2 and Windows Home Server 2011 in a Hypervisor; not exactly sure what I would be using it for but WHS won’t use more than 8 GB of RAM so I set the Hypervisor to use two processors and 8 GB of RAM. For storage I had two WD Blue 250 GB hard drives in a RAID 1 array for the boot/OS installation and three WD Green 2 TB hard drives for RAID 5 WHS storage. Following some initial setup confusion, the motherboard’s BIOS needed to be cleared before it would recognize the installed AXXRMS2AF080, the boot drives were connected to the main SATA 6 Gb ports and the storage RAID 5 array connected to the AXXRMS2AF080. Putting that RAID array offline in Windows Server 2008 R2 allowed me to add it as a dedicated drive to the Hypervisor and will supposedly give me the best performance. Everything was installed, set up and ready to go.

Well, almost ready. The AXXRMS2AF080 uses an LSI chip for RAID 0, 1, 10, 5 and 50 but has no on-board cache. No problem, lots of modern RAID cards share system memory. Ya, not this one or so it seems because you can’t configure it for write back caching, only write through caching. Meaning it was getting 180 MB/s reads and 20 MB/s writes. Abysmal to say the least. Taking it off the Hypervisor and playing around with it in Windows Server 2008 R2 did nothing for the performance. I messed around with every combination of stripe and allocation unit size did nothing to improve things.

Checking online for suitable RAID cards with a price point below $200 led me again and again to the HighPoint RocketRAID 2720SGL: PCI-e 8x with 8 6Gb/s SATA and SAS ports through two SFF-8087 cables (I’ll get into it in the review later). I ordered it from Amazon and the SFF-8087 cables from Monoprice and was happy to get everything installed. I had the card before the cables, the SGL version has no cables and is $90 less but otherwise identical, so I installed it in Windows and set up the drivers and management interface. Everything looked good.

The cables arrived and I hooked up the WD Green 2 TB drives to the RocketRAID 2720SGL, configured a RAID 5 array in the card’s BIOS and then watched a flashing cursor after POST. Hmm. Unhooked the drives and the system booted normally. Hooked the drives back up and hit the blinking cursor. Went into the motherboard BIOS and fiddled with any setting I could find that would effect storage and booting to no avail. Updated the motherboard BIOS and still couldn’t get the system to boot. Googling boot failures with the S1200BTL motherboard yielded no results. I gave up and left it alone.

The next day I decided to tackle it from the perspective of the RocketRAID 2720SGL and Googled rocketraid intel motherboard boot and came across people with the same issue: nothing booting, just a blinking cursor. They pointed to this suggestion from the HighPoint website FAQ which is no longer available.

Answer: Some motherboards may be unable to load the card’s BIOS into memory, especially if other devices (such as onboard RAID or SCSI controllers) are active. This could prevent the card, or other device, from booting the system
If these additional controllers are not needed, try disabling them using the motherboard’s BIOS menu.
If this is not an option, press the “End” key when the host adapter’s BIOS is first displayed – this will cancel the card’s BIOS load.
This should prompt the motherboard to skip the host adapter card, and proceed to the next device.Arrays and disks attached to the card will still be accessible through the operating system.
To avoid pressing the “End” during every boot session, try disabling some of the card’s BIOS features. To do so, flash (upgrade) the card’s BIOS, and access the BIOS sub-menu.
If you intend to boot from the host adapter card, disable the option listed as “Reallocate EBDA”. If you do not need to boot from the host adapter card, disable both the “Reallocate EBDA” and “INT13″ options. For more information about this upgrade procedure, please download the BIOS User Manual posted at this link:

http://www.highpoint-tech.com/manuals/Updating_BIOS.pdf

I downloaded the latest BIOS for the RocketRAID 2720SGL and followed the instructions for disabling Reallocate EBDA and INT13; to run at a command prompt type the following. The “/c” argument brings up a different menu to change BIOS features; it asked if I wanted to save the changes to a file and I tried it saving and not saving with the same result.

load.exe /c /v biosname.version (mine was rr2720.v15)

Rebooted the system and was finally back into Windows with a fully functioning hardware RAID 5 array. What a boondoggle.

7 Comments

  1. You saved my loads of time figuring out what to do! I had an Intel RAID array and when I inserted the Rocket (not RocketRAID, ordered the wrong one) card, it picked it up right away but my BIOS only loads 4 boot devices + addIn cards, so I could only see my 4x Vertex 4 RAID array, which I still had to configure and update before installing Windows 8 into it. Naturally I had to do that in Windows, but my BIOS couldn’t see my other raid array in bootup anymore. The Intel RAID utility booted just fine but it could discover it, so no boot into Windows. I eventually fixed it by disabling INT 13h on the card and it booted up just fine.

    I’ll receive the new RocketRAID in a couple of days but I have no doubt that this trick will work as well, tho the key combinations are different (had to press CTRL+M instead of CTRL+H).

  2. does anyone know what has to be disabled for options in order for me install an os onto the raid set and still be able to boot from flash drive?

  3. Just wanted to say thank you for this post. I am not sure this information exists anywhere anymore.

  4. Yep got mine off ebay, it wouldn’t boot, had to dig up this solution, and omg, flashing in dos is such a pain. On my motherboard I had to turn ahci off before booting off a usb would work to get to dos. I’m pretty sure I forget this each time and have to relearn it again:(

    I did find some info that flashing with a /e option would just skip the boot drive detect all together, but I didn’t try it. Just used the -c and disabled the two things mentioned so it wouldn’t conflict with my bios. It works now but highpoint should list this on their website on the main page of this products support page.

    So far so good, it only works with harddrives I guess, wouldn’t detect my dvd drive. I only use it for extra sata ports.

  5. I am having same issue, can you explain how to get to the disable part, unclear on how to get there.

  6. Thanks so much for this, I have a Highpoint 2740 and ran into this same boot issue when I migrated to a recently purchased Intel S1200BTL mobo. Wouldn’t have thought that something as basic as hitting the End key would fix my problem. Thanks again.

Leave a Reply

Subscribe to eBabble via email

Enter your email address:

My Sponsors

AbeBooks Click Here Elegant Themes Click Here BlueHost Click Here Amazon U.S. Click Here

Join eBabble on the socials

My Sponsors

Amazon Canada Click Here NewEgg Canada Click Here Book Depository Click Here eBay Canada Click Here

Pin It on Pinterest

Share This

Share this post with your friends!